All posts by admin

Ubuntu

Nach langem hin- und her überlegen bin ich mit meinem Desktop (früher Win10) auf Uuntu umgestiegen. Ich hab per Live-CD eigentlich alles mal durchprobiert:

  • ubuntu
  • kubuntu
  • gubuntu
  • debian (ja, alle desktop-flavours einzeln)

Debian testing wegen kde 5 aka plasma.

BTW: kde hat noch die gleichen probleme wie vor 20 Jahren: Konfigurieren des Desktops und benutzen des Desktops ist bunt vermischt, zumindest wenn man nicht alles locked.

Das einzige was akzeptabel rund läuft und zeitgemäße optik hat war tatsächlich ubuntu mit dem default unity …

Die umstellung ist jetzt zwei Wochen her.

Die ersten 5 Tage habe ich bissl was eingerichtet und dann wieder Win10 gebootet für Couchpotato-Kodi-Mode, dannach lief das auch und ich hab seit dem Windows nicht mehr benutzt. (Ich war etwas in versuchung wegen Civ6 aber das ist ein anderes Thema …)

Ich habe von steam über kodi bis zum firefox praktisch alles wichtige ohne neu konfigurieren umgezogen bekommen (kodi hat ein paar fixes in der DB wegen neuen pfaden gebraucht). Ich hab dann auch den zugriff aufs NAS auf NFS umgestellt (das hat etwas scripting gebraucht, mein NAS läuft nicht durch und NFS ist dafür nicht ganz so perfekt … hab ein script für nas starten per WOL, warten, NFS mounten und so).

Mittlerweile fühl ich mich deutlich wohler, es gibt ein paar kleinere schönheitsfehler:

  • suspend funktioniert nicht (wacht nicht rihtig auf und bootet dann regulär)
  • hybernate funktioniert … meistens. ab und an crashed der rechner beim aufwachen und muss regulär booten, meistens klappts aber

Beides kein drama mit SSD bootet es sich derart schnell dass ich länger zum unlocken brauche. Ich habe da das Asrock-Mainboard im verdacht, das hat auch unter windows nicht ohne weiteres standy mitgemacht.

A propos unlocking, das aktuelle Setup ist

  • 120GB SSD mit Ubuntu (crypt)
  • 2x 1,5TB als raid 1 mit crypt und lvm als datenplatte
  • 1x 300 GB mit crypt als scratchspace
  • 120GB SSD mit Win10 falls ich das doch nochmal booten will

Ist also alles schön verschlüsselt (das NAS war ja schon lange so), das einzige an das man potentiell rankommt ist das Windows das vermutlich demnächst wegen nichtbenutzung aufgeräumt wird.

Bug des Tages

Wird der Gateway in Windows mal auf 0.0.0.0 gesetzt (egal ob versehentlich beim IP konfigurieren oder durch dumme Software) und man korrigiert das bleibt die route da (yay). Die ist sogar reboot-fest, d.h. es geht kein Netzwerk mehr bis man die Route entweder per hand entfernt (adminrechte nötig, “delete route 0.0.0.0”) oder das Fixit-Tool dafür nutzt. Siehe KB